Group Management Issues

Incident Report for Lightning Systems

Update

There is to this day, still no response from Roblox's team. We will have to wait until Roblox introduces an alternate method for developers.

We are heavily sorry for the inconvenience this has caused.
Posted Apr 22, 2022 - 14:47 UTC

Investigating

The staff at Roblox released a security update globally without any warning or notice, causing collateral damage to ranking systems and so forth that heavily rely on ".ROBLOSECURITY" cookies.

This change means that when your current account session is accessed by a different IP address, Roblox automatically destroys the session which is essentially good for security but on our behalf and on the behalf of many other service providers this has totally broken ranking.

So when our machines attempt to communicate with Roblox's API through bot commands, Roblox recognises a different IP Address and destroys the cookie.
Posted Mar 09, 2022 - 14:39 UTC
This incident affects: Services (Group Management).